Chapter 4 Determining Cell Size

The third tutorial is designed to give you a demonstration in using the Cell Size Calculator to obtain the optimal cell size for your circuit as well as using the palette of standard geometries and vias. Some of the following topics are covered:

- The cell grid
- Using the Cell Size Calculator to determine cell size
- Using the Palette of Standard Geometries
- Vias

For this tutorial, you analyze a rectangular spiral with an airbridge, as shown in the figure below. First, the circuit is entered in the project editor, then an analysis is run using *em*. You observe your output data using the response viewer, Sonnet’s plotting tool. A comparison is made using a circuit with exact dimensions versus a circuit with approximations that yields a significant improvement in processing.
time. The goal of this tutorial is to teach you how to make wise choices in balancing the needed level of accuracy versus the processing time requirements and to teach you how vias are modeled.

The circuit is a 3 turn spiral inductor whose conductor width is 9.8 mils and spacing is 3.4 mils. The overall size is 150 mils by 150 mils. Before you enter the circuit in the project editor, you need to make some design decisions.

Calculating Cell Size for Non-Integer Dimensions

In general, you should follow these steps when determining your cell size:

- Determine critical parameters.
- Enter the critical parameters in the Cell Size Calculator to determine the optimal cell size with the minimal reduction in accuracy.

Before using the Cell Size Calculator to determine the cell size for your circuit, you must decide which parameters are the most critical. You use the most critical parameters to calculate the best cell size for your circuit in Sonnet.
In the case of the spiral inductor the most critical parameters are the conductor widths and spacings. The overall size of the spiral, 150 mils by 150 mils, is not as critical.

For this example, the conductor width is 9.8 mils and the spacing is 3.4 mils. These might be the values obtained from an optimization or synthesis software. In order to model these two dimensions exactly, it would be necessary to choose a cell size of 0.2. This cell size would require an inordinately large number of subsections and hence a prohibitive amount of processing resources. So you need to calculate a cell size that provides a level of accuracy within your tolerance while using less of your memory and processing time.

For more information about cell sizes and subsectioning, please refer to Chapter 4, “Subsectioning,” in the Sonnet User’s Guide.

Vias

The spiral inductor uses an airbridge to connect one end of the inductor to the box-wall port. Vias, which are a special kind of subsection which allows current to flow in the z-direction between metal levels, are needed to model the airbridge.

The via features in Sonnet are quite versatile. They can be used to create the many via structures commonly found in multilayer designs. In Sonnet, vias can connect between any two metalization levels. This allows the user to create internal “level to level” vias which extend between any two metalization levels in the circuit including the two outermost levels (Top and Gnd) or the present level and ground (GND). An internal “level to level” via is used to create the vertical portion of the airbridge in this example.

Sonnet’s vias use a uniform distribution of current along their length and thus are not intended to be used to model resonant length vertical structures. Keep the via lengths small with respect to a wavelength.

To create vias, use the project editor to enter via polygons where desired. Sonnet places subsectional vias (called “via-posts”) along the entire perimeter of the via polygon. This perimeter is always one cell wide. Vias extend in the direction presently selected in the Tools menu. The length of the via is equal to exactly the
Sonnet Tutorial

thickness of the dielectric layers which it traverses. The via-posts are rectangular cylinders with a horizontal cross-sectional area equal to one cell. If you make the cell size smaller, the vias become smaller with more of them along the edge of the via polygon. Of course, the length of the via is unchanged. Current in a subsectional via is uniform throughout the body of the via and is \(Z\) directed. Via loss is determined by the metal type used for the via.

For a detailed discussion of all the types of vias and how they are modeled, please refer to Chapter 18, “Vias and 3-D Structures” in the Sonnet User’s Guide.
Inputting the Circuit in the Project Editor

In this section of the tutorial, you input the circuit “spiral.son.” The complete circuit, with dimensions, is shown below.

![Diagram of the circuit with dimensions](image)

The dimensions of the example file, spiral.son.

Invoking the Project Editor

First, open the Sonnet task bar. If you do not yet know how to do this, please refer to “Invoking Sonnet,” page 15.
1 Click on the Edit Project button in the Sonnet task bar.

A pop-up menu appears on the task bar.

2 Select New Geometry from the pop-up menu.

The project editor window, with an empty substrate, appears on your display as shown below. The view shown in the project editor is a two-dimensional view from the top looking directly down on the substrate. The tool box, which allows easy access to commonly used functions, also appears on your display.

Specifying Box Settings

Before drawing the circuit, you must specify the parameters of the enclosing box, which includes the dimensions of the substrate and the cell size.
3 Select Circuit ⇒ Box from the project editor main menu.

The Box Settings dialog box appears on your display. This dialog box is used to set the box size and cell size dimensions for your circuit.

Using the Cell Size Calculator

You will enter the critical dimensions into the Cell Size Calculator to determine the optimal cell size. The automatic algorithm calculates the cell size which provides the desired accuracy while using the minimum of processing resources. This eliminates the need for you to do multiple analyses in order to find the optimal cell size.
4 Click on the Cell Size Calculator button in the Box Settings dialog box.

A dialog box appears on your display asking if you wish to go straight to the calculator or use the Wizard. For the first few times you use the Cell Size Calculator function, we suggest you use the wizard until you are familiar with how the calculator functions. The Wizard is already selected as the default choice.

5 Click on the Next button to continue using the Wizard.

The X Direction Target Entry box appears on your display. In the introduction to this tutorial, the trace width and spacing were identified as the critical dimensions. The critical dimensions are the same in both the x and y direction for this case. It is possible to have different dimensions be critical in each direction. Remember that the cell size does not have to be a square; the x and y dimensions of a cell may be different. Hence, you enter critical dimensions in both the x and y direction when using the Cell Size Calculator.
6 Enter 9.8 in the X Target text entry box and click on the Add button to the right.

The trace width, 9.8 mils, is added to the list of critical dimensions in the x direction.

7 Enter 3.4 in the X Target text entry box and click on the Add button to the right.

The spacing, 3.4 mils, is added to the list of critical dimensions in the x direction. This completes the list of critical dimensions in the x direction.

8 Click on the Next button to continue.

The Y Direction Target Entry box appears on your display. This is identical to the previous entry but applies to the y direction. Since the trace width and spacing are the same in both the x and y direction, the same values are entered for the y direction as were entered in the x direction.
9 Enter the values 9.8 and 3.4 in the same manner cited above for the x direction.

10 Click on the Next button to continue.

The Target Tolerance Entry box appears on your display. You may enter the tolerance of your dimensions as a function of percentage or length units. Your tolerance should be a non-zero value. The default tolerance is 5% which is a good value for this example. You do not need to change any settings.
11 Click on the Next button to continue.

The suggested cell dimensions are displayed, 3.4 mils by 3.4 mils for the cell size. This would make the trace width 10.2 mils.

12 Click on Finish to complete the Wizard and enter the suggested dimensions for the cell size.

The cell size dimensions now appear in the Box Settings dialog box. Note that when the new cell size is entered, the box size and Num. Cells entries are updated.

The cell size calculator used the original box size of 160 mils by 160 mils to arrive at a box size of 47 cells by 47 cells. To allow enough space for the spiral, we shall change the box size to 125 cells by 125 cells.

13 Enter 125 in the X text entry box in the Num. Cells row of the Box Settings dialog box.

This sets the x dimension of the box, and thereby, the substrate, to 125 cells. The box size is updated to 425 mils.

14 Enter 125 in the Y text entry box in the Num. Cells row of the Box Settings dialog box.

This sets the Y dimension of the box, and thereby, the substrate, to 125 cells.
Note that when these values are entered, the box size value is updated to correspond to the new number of cells.

15 Click on the OK command button in the Box Settings dialog box.

The dialog box disappears from your display and the substrate is updated to show the new size. The substrate appears blank with no cell grid visible. In fact, the cell size is simply too small for the grid to show up at a magnification of 1.0. In this
particular case, zooming in to a magnification of approximately 6.0x makes the cell grid visible. The magnification level appears in the Status Bar at the bottom of the project editor window.

Setting the Dielectric Layers

Next, you need to specify the dielectric layers.

16 Select Circuit ⇒ Dielectric Layers from the project editor main menu.

The Dielectric Layers dialog box, which allows specification of the dielectric layers of the structure, appears on your display providing you with an approximate “side view” of your circuit. The project editor “level” numbers appear on the left. A “level” is defined as the intersection of any two dielectric layers and is where your circuit metal is placed.
This circuit requires two metal levels in order to place an airbridge above the spiral. Since a level is defined as the intersection of two dielectric layers, the addition of a dielectric layer also adds another metal level.
17 Click on the Above button in the Dielectric Layers dialog box.

The Dielectric Editor dialog box appears on your display. This dialog box allows you to edit the parameters of a dielectric layer in your circuit.

18 Enter a value of “250” in the Thickness text entry box and Air in the Mat. Name text entry box.

This dielectric layer is the air above the actual microstrip. The layer thickness has absolutely no impact on execution time. Remember, the analysis is done inside of a six-sided metal box, so there is a metal top cover above the 250 mils of air. Specifying a small number for this thickness moves the top cover closer to the circuit metalization, providing stronger coupling between the top cover and the circuit metalization. This cover is set high enough to prevent coupling. Since our substrate thickness is 25 mils, this means the top cover is 10X this distance; the reason 250 mils was selected.

19 Enter a value of “1.0” in the Erel text entry box.

This is the dielectric constant for air. This value may already be present. The rest of the parameters are correct for air and do not need to be edited.

20 Click on the OK button to close the dialog box and add the dielectric layer.

The Dielectric Layers dialog box is updated to include the new entry.
21 Enter a value of “1.0” in the Thickness text entry box in the middle entry line of the Dielectric Layers dialog box, presently labeled Unnamed.

This specifies a 1 mil thick layer. The other parameters define air as the dielectric so there is no need to edit them. To edit a layer entry, double-click on the entry line to open the Dielectric Editor dialog box which allows you to change the parameters.

22 Double-click on the bottom entry line to open the Dielectric Editor dialog box.

23 Enter a value of “25.0” in the Thickness text entry box.

This specifies a 25 mil thick substrate.

24 Enter a value of “9.8” in the Erel text entry box.

Since the dielectric constant for alumina is 9.8, this defines a 25 mil thick alumina substrate for your circuit.

25 Enter Alumina in the name text entry box.

This identifies this dielectric layer as alumina.
26 Click on the OK button to close the dialog box and apply the changes.

The Dielectric Layers dialog box should appear similar to that shown below.

![Dielectric Layers dialog box]

Note that the thickness of each layer must be specified. If not, the default value, 0.0, causes *em* to issue an error message and stop execution.

The setup of the box size, and dielectric layers is complete. The only metal type used for this circuit is lossless, the default metal type available in any new project file. In the next section, you input the metal polygons which make up the circuit.

27 Click on the OK command button to apply the changes and close the dialog box.

Palette of Standard Geometries

The metalization in this circuit consists of a rectangular spiral and airbridge. You use the Palette of Standard Geometries, pre-defined metalization shapes, to add the rectangular spiral to your circuit.
**Sonnet Tutorial**

28 Select “1” from the Level drop list on the tool bar to go to level 1 in your circuit.

The view in the project editor is now level 1 where you wish to place the spiral.

29 Select **View ⇒ Measuring Tool** from the project editor main menu.

The measuring tool Readout dialog box appears on your display. You will use the Readout dialog box to position the anchor where you want to place the rectangular spiral on the substrate.

30 Click on the Anchor button in the Readout dialog box.

The Anchor Setup dialog box appears on your display.

31 Enter “132.6” in the X text entry box and “292.4” in the Y text entry box in the Anchor Setup dialog box.

These values give the position of the upper left hand corner of the rectangular spiral in your circuit. The upper left hand corner was selected because this is the reference point used in the standard palette spiral inductor.

32 Click on the OK button to close the dialog box.

The Anchor, a large +, appears on your substrate. The anchor is used to help position the spiral.

---

**NOTE:**

The precision used in placing the geometry in this example is done to ensure that the results are consistent with results displayed later in the tutorial. In many cases, the exact placement of the spiral would be unimportant.

---

33 Select **Tools ⇒ Add Metalization ⇒ Rectangular Spiral** from the project editor main menu.

The Rectangular Spiral Attributes dialog box appears on your display.

34 Enter “3” in the Number of Turns text entry box.

The rectangular spiral has 3 turns.
Enter “10.2” in the Conductor Width text entry box.

The width of the conductor for the spiral is 10.2 mils; the value obtained in the calculations at the beginning of this tutorial.

Enter “3.4” in the Conductor Spacing text entry box.

The spacing for the spiral is 3.4 mils; the value obtained in the calculations at the beginning of this tutorial.

Enter “153” in the First Length and Second Length text entry boxes.

This sets the overall dimensions of the rectangular spiral to 153 by 153; the values obtained in the calculations at the beginning of this tutorial.

Click on the OK button to add the Spiral.

A black outline of the spiral with a cursor fixed at the upper left hand corner appears on your circuit display. As you move the mouse the position of the cursor and spiral change accordingly.

TIP

You may want to zoom in on the location of the spiral to make it easier to position the spiral before adding it to your circuit. You may zoom in using the Space Bar, middle button on your mouse, or the button on the tool bar.

Move the spiral until the cursor is on the Anchor and click the left mouse button.

The metalization of the spiral is drawn on your circuit. This places the rectangular spiral at the desired location in your circuit. Note that the outline of the polygon extends past the metalization at the inside beginning point of the spiral. This is
because the polygon edge lies between two cell boundaries. You will need to zoom in on this section of the circuit to observe this. The metalization that *em* analyzes must fall on the cell grid and is shown by the cell fill pattern.

Next, you need to extend the conductor to the box wall.

**40** If you have not already done so, zoom in on the end of the conductor.

Your circuit should appear similar to that pictured below.

**41** Click on the Reshape button in the project editor tool box.

This mode, as indicated by the cursor, allows you to select points on a polygon and move them.
42 Drag your mouse to select the end points of the conductor.

The two points appear highlighted.

43 Select Modify ⇒ Snap To from the main menu.

The Snap Objects dialog box appears on your display.

44 Click on the Top radio button in the Box Walls section of the dialog box.

This will extend the conductor to the box wall.
Click on the OK button to close the dialog box and apply the changes.

The full view of your circuit should resemble the one shown below.
Creating an Airbridge

46  Zoom in on the area of the upper left hand corner of the spiral to the left box wall.

47  Click on the Add a Rectangle button in the project editor tool box.

48  Drag the mouse to create a rectangle 119 mils by 10.2 mils.

As you move your mouse when adding the rectangle, the size of the polygon is shown in the status bar. Use this to get the proper size rectangle. This polygon is a feedline which connects to the spiral using an airbridge.
49 Move the rectangle so that the left end is on the box wall and the top lines up with start of the spiral.

Your circuit should look like this:

50 Click on the Up One Level button on the tool bar.

Level 0 of your circuit is displayed. There is no metalization on this level yet, however, the outline of the metalization placed on Level 1 appears as a dashed line.
Chapter 4  Determining Cell Size

51 Add a rectangle which extends from three cells after the end of the feed line to a cell before the beginning of the spiral (47.6 mils by 10.2 mils).

Zoom in if you need to. Use the dashed lines as guides for the ends of the polygon.

52 Select Tools ⇒ Add Via ⇒ Down One Level if it is not already selected.

Any vias added will extend down one level from the originating level.

TIP

You may click on the Via Down One Level button in the tool box.

53 Hold down the Shift key and select Tools ⇒ Add Via ⇒ Draw Rectangle to add the via polygon.

Holding down the shift key allows you to add multiple via polygons to your circuit. If the Via Direction Notice appears, click on OK to close the message. The Add Via Rectangle mode is indicated by a change in the appearance of the cursor.
54 Click on the upper corner of the outline of the metal below and drag your mouse to the lower corner of the metal polygon, then release the mouse.

The via polygon is drawn in your circuit and should appear similar to that shown below. Note that the arrows on the via point downward to indicate the direction of the via polygon.
Click on the upper right hand corner of the metal polygon on this level and drag your mouse over two cells and down three. Release the mouse.

A via polygon connecting the airbridge to the beginning of the spiral is added to your circuit as shown below. Note that the first via polygon does not have metal in the middle but this one does. A via polygon has metalization in a one cell thick wall around the perimeter. The second via polygon is only two cells wide so that there is no space in the middle.
If you go down one level, the vias now appear in your circuit, but with the triangles pointing up, to indicate that the via originated on the level above. The via on the right overlaps the metal of the spiral; the overlap area does not appear in reverse video, but the triangle indicates where the edge of the via polygon is.

56 Press the Escape key to return to pointer mode.

This exits Add Via mode.

Adding Ports and Reference Planes

57 Go to Level 1 if you are not already there.

58 Hold down the Shift key and click on the Add Port button in the project editor tool box.

Holding down the shift key allows you to add multiple ports without returning to pointer mode.

59 Click on the feedline at the left box wall.

This adds Port 1 to the circuit.
60 Click on the end of the conductor at the top box wall.

This adds Port 2 to the circuit.
61 Push the Escape key to return to pointer mode.

62 Select Circuit ⇒ Ref. Planes/Cal. Length from the project editor main menu.

The Reference Planes/Calibration Lengths dialog box appears on your display. In the list, Left, Right, Top and Bottom refer to the box wall on which the port is situated.

63 Select the “Left” entry in the list of reference planes.

The Left entry line is highlighted.

64 Click on the Fixed radio button.

This enables the text entry box for the fixed value. This choice uses a fixed value for the reference plane.

65 Enter “119” in the Length text entry box for the Fixed radio button and click on the Apply button.

The reference planes extends from the port on the left side of the box 119 mils into the circuit. The left entry line now reads “Fixed, plane length of 119 mils.”
66 Select the “Top” entry in the list of reference planes.
   The Top entry line is highlighted.

67 Click on the Linked radio button.
   This choice allows you link the reference plane to a point on a polygon. If that
   point is moved for any reason, the length of the reference plane changes
   accordingly.

68 Click on the Mouse button next to the linked radio button to select a point.
   The dialog box disappears and the cursor changes to a cross.

69 Click in the circuit on the corner of the spiral as pictured below.
   You will need to zoom in on this area of the circuit.

   ![Diagram showing point selection](image)

   The dialog box re-appears. The top entry line now reads “Linked, distance from
   port: 132.6 mils.”

70 Click on the OK button to apply the reference planes and close the dialog
   box.
   The reference planes extend from the box wall for the length input in the
   Reference Planes dialog box. When analyzed by *em*, the circuit is automatically
   de-embedded to the reference planes when the De-embed option is selected. De-
   embedding is the process by which the port discontinuity and any reference plane
   lengths are removed from the analysis results.
Note that the fixed length reference plane is represented by a solid black arrow on the circuit and the linked reference planes is shown by the outline of an arrow.

Inputting the circuit is now complete. Your circuit should appear as shown below.

Select File ⇒ Save from the project editor main menu and save the file under the name “spiral.son” in your working directory.

The Save dialog box appears on your display. You need to save the circuit file before analyzing with em.

**Em - The Electromagnetic Simulator**

In the next part of this tutorial, you analyze the circuit “spiral.son” which you input in the project editor.
Chapter 4  Determining Cell Size

Setting Up the Analysis

72 Select *Analysis ⇒ Setup* from the project editor main menu.

The Analysis Setup dialog box appears on your display. For this circuit, you will analyze using an adaptive sweep from 0.2 GHz to 2 GHz. An adaptive sweep provides approximately 300 data points in the band. For a detailed discussion of Adaptive Band Synthesis, see Chapter 9, “Adaptive Band Synthesis (ABS),” in the *Sonnet User’s Guide*.

73 Select Adaptive Sweep (ABS) from the Analysis Control drop list if it is not already selected.

The text entry boxes for the sweep are updated for an adaptive sweep.

74 Enter “0.2” in the Start text entry box and “2” in the Stop text entry box.

This defines the frequency band of the adaptive sweep as 0.2 GHz to 2.0 GHz.

Selecting Run Options

Run options for *em* are available in the Analysis Setup dialog box in the project editor. This example uses only the De-embed option, which is set by default.

De-embedding is the process by which the port discontinuity and any reference plane lengths are removed from the analysis results. Inaccurate data may result from failing to implement this option, even when you are not using reference planes. For a detailed discussion of de-embedding refer to Chapters 7 and 8 in the *Sonnet User’s Guide*.
The analysis setup is now complete. The dialog box should appear similar to that shown below.

![Analysis Setup Screen]

75 Click on the OK command button to apply the changes and close the dialog box.

76 Select File ⇒ Save from the project editor main menu.

This saves the analysis setup as part of your project file. You must perform the save before running em. If the file is not saved when em is invoked, a request to save the file appears before em executes.

### Executing the Analysis

77 Click on the Analyze button on the project editor tool bar.

The analysis engine, em, is launched and the analysis monitor appears on your display with the Response Data window shown. As the analysis progresses, the response data is output to the Analysis monitor and the progress bar is updated. When the analysis is complete, the “Analysis successfully completed.” message appears in the analysis monitor window.
Chapter 4  Determining Cell Size

Viewing your Response

In the next part of this tutorial, you plot an equation in the response viewer and compare the data to the analysis results of the circuit analyzed at the exact dimensions.

78 Select Project ⇒ View Response ⇒ New Graph from the analysis monitor main menu.

The response viewer appears on your display with the curve group spiral which includes the DB[S11] measurement. Note that since the analysis is an adaptive sweep, symbols only appear on the discrete data points.

You will use the equation for inductance to plot the inductance of spiral.son and the inductance of the circuit which uses the exact dimensions so that you can compare the results.
NOTE: You can invoke the response viewer as soon as the analysis of one frequency is complete. To input subsequent information produced by em, select Graph ⇒ Freshen Files from the response viewer menu.

TIP
You could also use the View Response button on the analysis monitor’s tool bar to invoke the response viewer.
Right-click in the Curve Group legend and select “Add Equation Curve” from the pop-up menu which appears. Or you may select Curve ⇒ Add Curve Group from the main menu of the response viewer.

The Add Equation Curve dialog box appears on your display.
80 Select “Inductance2 (nH)” from the Equation drop list.

The equation for inductance appears in the Arguments section of the Add Equation Curve dialog box as shown below. Inductance2 is the series inductance and does not include any capacitance to ground. The definition of any given equation is displayed in the Equation Body section of this dialog box.
81 Click on the OK button to close the dialog box and apply the changes.

You may not plot a data curve and an equation curve on the same axis of a plot; therefore, when you add an equation curve, it is necessary to delete the existing data curve. A warning message about the deletion of the data curve appears as shown below.

Click OK to close the warning message box.

If you do not wish to have this warning appear, click on the “Don’t show me this again” checkbox before you click on the OK button.

The plot is updated with the inductance of your circuit as a function of frequency.
Adding a File to a Graph

For comparison, add the project file for the spiral inductor analyzed at the exact dimensions. The project file for the exact circuit, which includes the response data, has been provided.

83 Copy the example, Spi_exact, to your working directory.

You can access the example through the online manuals. If you do not know how to do this, see “Obtaining the Example Projects,” page 17. Save the file to your working directory.

84 Click on the Add File button on the tool bar of the Response Viewer.

A Browse dialog box appears on your display. Use the browser to locate the “spi_exact.son” project file which was copied in the previous step.

If a data curve is presently displayed in your plot, adding another project file would automatically add the measurement DB[S11] to your plot. However, in the case of an existing equation curve, this is not done. Instead, the warning message, shown below, appears on your display.

85 Click on the OK button to close the message.

86 Right-click on the legend and select “Add Equation Curve” from the pop-up menu which appears.

The Add Equation Curve dialog box once again appears on your display.

Inductance 2 is already selected as the type of equation since you selected it previously, but you need to change the project being used as the input for the equation.
87 Click on the Edit button in the Add Equation Curve dialog box.
The Argument Entry dialog box appears on your display.

88 Select “spi_exact” from the project drop list.
The Argument Entry dialog box should appear similar to what is pictured below.

89 Click on the OK button to close the dialog box and apply the changes.
The plot now displays the inductance of both projects. As you can see the results achieved with the estimated circuit are very close to those of the exact circuit; however, the estimated circuit only took a fraction of the processing time due to a much bigger cell size.
Sonnet Tutorial

The graph title was added by right clicking in the area above the graph in the plot window, then selecting Options from the pop-up menu that appears. The title is entered in the Graph Options dialog box opened by selecting this command.

This completes the third tutorial.