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Introduction
In a significant step towards the inter operability of high frequency design tools, 
Applied Wave Research (AWR) has provided the EM Socket in Microwave 
Office 6.0 or higher which allows you to use your completely integrated “solver 
on request.” Now you can choose the design flow you prefer and maintain 
synchronicity between your reference design and the EM structures that are part 
of your layout. 

Sonnet has taken advantage of this opportunity by creating the Microwave Office 
Interface (MOI) which allows for the seamless incorporation of Sonnet’s world 
class EM simulation engine, em, into the Microwave Office 6.0 or higher 
environment. You can take advantage of Sonnet’s accuracy without having to 
learn the Sonnet interface. Although, for advanced users who wish to take 
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advantage of powerful advanced features not presently supported in the integrated 
environment, the partnership of AWR and Sonnet has simplified the process of 
moving EM projects between Microwave Office and Sonnet. 

For a detailed discussion of the Microwave Office Interface, its modes of 
operation and translation issues, please see Chapter 14, “Microwave Office 
Interface” in the Sonnet User’s Guide.

The Microwave Office Interface (MOI) tutorial is designed to give you a brief 
overview of the interface between Sonnet and AWR’s Microwave Office. This 
tutorial assumes that you are familiar with the basics of using both Sonnet and 
Microwave Office. If this is not true, we recommend referring to the appropriate 
documentation. If you are new to Sonnet, we suggest performing the tutorials in 
the Sonnet Tutorial manual, available as part of the hardcopy manuals set or in 
PDF format through the Sonnet task bar before using this tutorial. 

Tutorial Topics
The following topics are covered in this tutorial:

• Editing in Microwave Office, editing in Sonnet, and working out-
side of Microwave office.

• Opening Sonnet’s project editor from within Microwave Office.

• Setting up an Adaptive Band Synthesis sweep for the Sonnet analy-
sis engine.

• Running a simple analysis in Microwave Office using Sonnet’s 
analysis engine, em.

• Observing response data in both Microwave Office and Sonnet.

• Exporting an EM structure from Microwave Office to a Sonnet 
project.

• Importing a Sonnet project into Microwave Office.
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Obtaining the Example Project
The Microwave Office example project for this tutorial is supplied with your 
Sonnet software installation and is available through the PDF manuals on your 
computer. The Application Examples interface, accessed in PDF format on your 
computer, allows you to load the example project directly into Microwave Office. 

NOTE: You must have Adobe Acrobat Reader installed on your system to access the 
example interface in PDF format. If you do not have the program, it is 
available for installation by selecting Admin ⇒ Install Acrobat from the 
Sonnet Task Bar main menu.

To copy the Lowpass project to use in this tutorial, do the following:

1 Click on the Manuals button on the Sonnet Task Bar.

The file sonnet_online.pdf is opened on your display. 

2 Click on the Application Examples button in the PDF document.

3 Click on the Complete List button. 

A page appears with a complete list in alphabetical order of the example files.

4 Click on Lowpass in the list.

This will take you to the Microwave Office example project in the Application 
Examples. 
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5 Click on the Load into Microwave Office button at the top of the page.

Microwave Office is invoked on your display with the project “lowpass.emp” 
opened. It should appear similar to the picture shown below.

6 Double-click on “3 Stage Low Pass Filter” under Circuit Schematics in the 
project browser window.

This circuit uses the EM structure “Low Pass Filter” by connecting together three 
of the structures.

7 Double-click on “Graph 1" under Graphs in the project browser window.

The graph appears in the Microwave Office window. Note that the graph is empty 
since no analysis has yet been run on your Microwave Office project.

Project Browser
window
74



Chapter 5  Microwave Office Interface Tutorial
8 Double-click on “Low Pass Filter” under EM Structures in the project 
browser window.

This opens the EM structure “Low Pass Filter” in the Microwave Office window. 
This is presently the active display indicated by the colored title bar.

9 Select View ⇒ New 3D View from the Microwave Office main menu.

A 3-dimensional view of the EM structure appears in the Microwave Office 
window.

10 Select Window ⇒ Tile Vertical from the Microwave Office main menu.

This command makes all four open windows the same size and fills all the space 
available. Your display should now appear similar to the picture shown below. 
The order in which the views are displayed may vary. 
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11 Select File ⇒ Save Project As from the Microwave Office main menu.

The Save As browse window appears. Save the project in your working directory. 
This allows you to save any changes you make to the circuit and avoid corrupting 
the example file.

Editing in Microwave Office 
You may choose to edit your EM structure in Microwave Office or use the Native 
Editor, which in this case is Sonnet’s project editor. When using Microwave 
Office to edit your structure, you remain in the Microwave Office environment, 
editing your EM structures and controlling Sonnet analysis options using options 
available in Microwave Office. The Sonnet analysis engine, em, is invoked from 
Microwave Office and the analysis results displayed in Microwave Office and, 
optionally, in Sonnet. This section of the tutorial will demonstrate how to select 
Sonnet as your analysis engine, how to setup the analysis in Microwave Office, 
how to execute the analysis and how to observe analysis results in Sonnet Engine 
Only mode.

TIP
The Sonnet analysis engine must be selected for each EM structure in the Micro-
wave Office project.
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Selecting Sonnet as your EM Analysis Engine
1 Right-click on the EM Structure “Low Pass Filter” in the Project Browser 

section of the Microwave Office window as shown below.

A pop-up menu appears on your display.

EM structure
Low Pass Filter
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2 Select “Set Simulator” from the pop-up menu.

The Select a Simulator dialog box appears on your display.

3 Click on the “Sonnet 3D Planar Electromagnetic Simulator” checkbox. 

This selects em, Sonnet’s electromagnetic simulator engine, as the engine to use 
when performing analyses on the Low Pass Filter structure in Microwave Office. 

Click on the OK button to close the dialog box and apply the changes.

Selecting Analysis Controls

Sonnet provides some basic analysis controls within the Microwave Office 
environment for Sonnet Engine Only mode. To view and/or set these controls, do 
the following:
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4 Right-click on the EM Structure “Low Pass Filter” in the Project Browser 
section of the Microwave Office window as shown below.

A pop-up menu appears on your display.

5 Select “Options” from the pop-up menu.

The Options dialog box appears on your display with the General Tab selected.

EM structure
Low Pass Filter
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6 Click on the “Sonnet Options” tab in the Options dialog box.

The appearance of the dialog box changes and should appear similar to the picture 
shown below.

The ABS sweep across the full band is already set up by default, so you will need 
to take no action to setup the ABS sweep for Sonnet.

The Adaptive Sweep Settings control allows you to specify whether or not you 
want adaptive processing to be used when generating the S-parameter results. In 
Sonnet, the adaptive technique is called Adaptive Band Synthesis (ABS). If you 
disable Use Adaptive Band Synthesis, the analysis engine analyzes the circuit at 
each frequency specified in Microwave Office. This is recommended if you have 
fewer than five frequencies requested by Microwave Office.

If, however, you specified five, or more, frequencies in Microwave Office, then it 
is usually more efficient to enable Use Adaptive Band Synthesis. When enabled, 
the analysis engine does an ABS sweep over the specified frequency band first, 
and then it uses the adaptive results to generate S-parameters at each of the 
Microwave Office frequencies. This allows you to specify a very fine frequency 
resolution in Microwave Office, with hundreds or even thousands of individual 
frequencies, and obtain those results in the same time it would take to compute 5-
10 frequencies without adaptive processing.
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The Global project analysis frequencies for this Microwave Office project are 
from 5 to 35 GHz in 0.5 GHz steps. In this case, the default setting for Sonnet, full-
band ABS, is the most efficient choice.

7 Click on the Compute Current Density checkbox to select this run option.

You check the Compute Current Density control to enable generation of current 
density information when the analysis engine runs. By default, current density 
information is not generated. If you have already run the analysis engine with this 
control enabled, the View Currents button will be active. Later in the tutorial, you 
use this button to launch the Sonnet Current Density Viewer.

You may also wish to view the Sonnet subsectioning information by pressing the 
View Subsections button. Experienced users often find it useful to view this 
information prior to analyzing so that they can assess whether the subsectioning 
is appropriate for their processing time and accuracy requirements.

8 Click on the OK button to close the dialog box and apply the changes.

Running the Simulation

When using Microwave Office as the editor and you invoke a simulation, 
Microwave Office sends the geometry information of the EM structure to Sonnet 
along with the analysis controls. When the EM simulation is complete, Sonnet 
returns the requested analysis data.

To run the simulation, do the following:
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9 Select Simulate ⇒ Analyze from the main menu of Microwave Office.

A status window indicating the progress of the EM simulation being performed by 
the Sonnet analysis engine, em, appears on your display as shown below. 
Depending on your computer, the EM analysis may take a few minutes to 
complete. 

Once the simulation of the EM structure is complete, the status window is closed. 
The analysis of the complete circuit in the Microwave Office project is completed 
very quickly. You may now observe the results. Please note again that although 
Sonnet produced approximately 300 data points as the result of the ABS sweep, it 
returned data for only the 61 data points requested by Microwave Office.

During an ABS sweep, em analyzes at the beginning and end of the desired 
frequency band. Using an iterative process, em then analyzes at other discrete 
frequencies and determines a rational polynomial fit to the S-parameter data 
within the frequency band. The data produced by the full analysis at specific 
frequency points is the discrete data. Once a rational polynomial fit is achieved 
with an acceptable error, the frequency response across the specified bandwidth is 
calculated. The data generated using the rational polynomial is the adaptive data. 
For this particular ABS sweep, em performed a full analysis at 7 frequency points. 
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The S-parameter data returned from Sonnet to Microwave Office may be plotted 
using the graph capability in Microwave Office. For your convenience, a graph 
has already been set up in the example project.

10 If the graph is not already displayed in Microwave Office, double-click on 
Graph 1 in the Project Browser. 

The plot should appear similar to the one pictured below.

It is not possible at this time to display the current density data created by Sonnet 
within the Microwave Office environment, but you may invoke Sonnet’s current 
density viewer from Microwave Office.

11 Once again, right-click on “Low Pass Filter” in the Project Browser section 
of the Microwave Office window.

A pop-up menu appears on your display.

12 Select “Options” from the pop-up menu.

The Options dialog box appears on your display with the General tab selected.

Microwave Office Plot
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13 Click on the “Sonnet Options” tab in the Options dialog box.

The appearance of the dialog box changes and should appear similar to the picture 
shown below.

14 Click on the View Currents button to open Sonnet’s current density viewer.

This button is not enabled unless an analysis has been run with the Compute 
Current Density run option enabled. The current density viewer appears on your 
display. Note that when you open the current density viewer, Microwave Office 
is not locked since you are not changing the geometry or producing response data. 
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15 Click on the Down Level button to view the lower metal level.

Level 1 of Low Pass Filter.son is displayed for the frequency 5 GHz. 

The default animation setup for the current density viewer is to animate as a 
function of frequency, so it is a simple operation to view the change in current 
density in your structure as a function of frequency. It is important to note that 
current density data only exists for the seven discrete data points where a full 
analysis was done. The adaptive data does not include current density data.

TIP
For more details on using the current density viewer in Sonnet please refer to the 
first tutorial in the Sonnet Tutorial manual and to online help for the current den-
sity viewer. 

16 Select File ⇒ Exit from the current density viewer main menu.

This exits the current density viewer. During the normal design process, observing 
the response data may lead to making changes in the EM structure. You would edit 
the EM structure in Microwave Office before once again simulating the circuit.
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The next section of this tutorial discusses using the native editor in the Microwave 
Office Interface in which you use the Sonnet project editor to edit your EM 
structure.

Native Editor
If you choose the native editor, Sonnet’s project editor, you not only use Sonnet 
as your electromagnetic simulator but also EM structure editor. The native editor 
allows you to take advantage of all the capabilities unique to Sonnet including 
thick metal, dielectric bricks, autogrounded ports, etc. Using the native editor 
requires that you are already conversant with Sonnet software or will have to use 
Sonnet documentation to gain familiarity with the Sonnet environment.

For this tutorial, you will define a physically thick metal in Sonnet using the Thick 
Metal definition. The use of physically thick metal in this circuit is done solely for 
purposes of demonstration, not as a design decision. This metal model is a feature 
not available with Microwave Office and will be used to demonstrate using 
Sonnet’s project editor as the native editor.

In the previous section of the tutorial, you have already selected Sonnet as your 
EM simulator. Now you will select Sonnet as your editor as well.
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17 Right-click on Low Pass Filter in the project browser in Microwave Office 
and select “Options” from the pop-up menu.

The Options dialog box appears on your display with the General tab displayed.

18 Click on the Native Editor radio button to select Sonnet as your editor.

Note that Sonnet is displayed as the simulator to the left of the radio buttons.

19 Click on the Currents checkbox in the Save Results in Document section of 
the dialog box.

As in the first part of the tutorial, you are going to generate current density data 
for the EM structure when you perform the analysis. To store this data for future 
use, you must choose to save the current density data as part of your Microwave 
Office project. Selecting this checkbox includes the current density data in the 
Microwave Office project when it is saved. Be aware that saving current density 
data may increase the size of your project file substantially.
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20 Click on the OK button to close the dialog box and apply the changes.

Once you have completed this step, you are unable to edit the EM structure in 
Microwave Office. If you attempt to edit the EM structure in Microwave Office, 
you will receive the warning pictured below. 

Next, you edit the circuit using the project editor in Sonnet.

Editing your EM Structure in Sonnet
21 Right click on Low Pass Filter in the project browser window in Microwave 

Office and select “Open in Native Editor” from the pop-up menu.

Sonnet’s project editor (xgeom) appears on your display with the EM structure 
Low Pass Filter open displaying the top most metal level 0.

22 Click on the Down One Level button on the project editor tool bar.

Metal level one appears in the project editor’s window. You will change all of the 
metal on this level to thick metal, but first you must define the metal type.
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23 Select Circuit ⇒ Metal Types from the project editor main menu. 

The Metal Types dialog box appears on your display.

24 Click on the Add button to add a new metal type.

The Metal Editor dialog box appears on your display.

25 Enter “Thick Gold” in the Name text entry box.

This name is used to select this metal type.

26 If it is not already selected, select “Thick Metal Model” from the Type drop 
list.

This type is used to model physically thick metal. The other metal types are 
modeled as zero-thickness metal. For a discussion of thick metal modeling click 
on the Help button in the dialog box and refer to the “Thick Metal” chapter in the 
Sonnet User’s Guide. 
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27 Enter “4.09E7” for the conductivity and “3” for the thickness. 

These parameters will be used to calculate the loss of the metal. The default 
number of two sheets is adequate for this example.
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Once you have entered all of the parameters, click on the OK button to close the 
dialog box and apply the changes. Thick Gold now appears in the list in the Metal 
Types dialog box.

28 Click on the OK button in the Metal Types dialog box to close the dialog box 
and apply the changes.

29 Drag the mouse around all of the metal polygons on level 1 to select all the 
polygons.

All the polygons are highlighted to indicate that they are selected.
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30 Select Modify ⇒ Metal Properties from the project editor main menu.

The Metal Properties dialog box appears on your display.

31 Select “Thick Gold,” the metal type you just defined, from the Metal drop 
list in the Metal Properties dialog box.

This applies thick metal to all the selected polygons.

32 Click on the OK button to close the dialog box and apply the changes.

Note that all the polygons now use a different fill pattern to indicate that they are 
using the Thick Metal metal type.

33 Click on the Up One Level button on the project editor tool bar.

This changes the view in the project editor to level 0 of the circuit which contains 
the airbridges for the circuit.

34 Change the metal type of all the polygons on this level to “Thick Gold” in the 
same manner as you changed the metal type on level 1. 

All the metal in the circuit now uses the “Thick Gold” metal type.
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35 Click on the Save button on the project editor tool bar to save your changes.

The project editor will prompt you to remove the analysis results stored in the 
project, since the changes made in the geometry make that data obsolete. 

36 Click on the Delete button to delete the inconsistent results.

37 Select File ⇒ Exit from the project editor main menu.

The project editor disappears from your display. When you open the native editor 
in Microwave Office, the Microwave Office framework is “locked” and you are 
unable to make any changes to your project or run any simulations. When the 
project editor is closed, then Microwave Office is unlocked and you may once 
again make changes in the Microwave Office framework. When you view 
Microwave Office note that Thick Metal is now included on the Materials list in 
the Microwave Office project browser as shown below. The fill pattern in the EM 
structure has changed to indicate the use of Thick Metal. Since the thick metal 

model is not available in Microwave Office, the loss definition is converted to the 
Microwave Office model which uses the DC resistance, Rdc, in ohms/sq and the 
skin effect coefficient, Rrf. The thick metal model definition is maintained as part 
of the Sonnet project stored in Microwave Office but is not displayed.

Running the Simulation

When you complete making your changes to the structure, save the changes and 
exit back to Microwave Office, the geometry specifications are sent to Microwave 
Office. In effect, the Sonnet project is stored as part of the Microwave Office 
project. When the analysis is run, the stored Sonnet geometry information is sent 
to Sonnet, the EM simulation is executed, then analysis data is returned.

Thick Gold entry
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38 In Microwave Office, select Simulate ⇒ Analyze from the main menu.

A status window indicating the progress of the EM simulation being performed by 
the Sonnet analysis engine, em, appears on your display. Depending on your 
computer, the EM analysis may take a few minutes to complete. The processing 
time for this part of the tutorial will be increased over the first part, since the use 
of thick metal does require more processing time in Sonnet.

Once the EM simulation of the EM structure is complete, the status window is 
closed. The analysis of the complete circuit in the Microwave Office project is 
completed very quickly. You may now observe the results. Please note again that 
although Sonnet produced approximately 300 data points as the result of the ABS 
sweep, it returned data for only the 61 data points requested by Microwave Office.

The S-parameter data returned from Sonnet to Microwave Office may be plotted 
using the graph capability in Microwave Office. For your convenience, a graph 
has already been set up in the example project. It should now appear similar to the 
graph displayed below. You may also observe the current density data in the 
current density viewer using the same method described starting at step 12.

If you were interested in seeing the effects of design changes on only the EM 
structure before analyzing your whole circuit, it is possible to remain in Sonnet 
after making your changes. You may run the EM analysis from Sonnet, and 
observe the results using the various Sonnet modules. Once you were satisfied that 
the EM structure was meeting your specifications, you would exit Sonnet and 

Link to this 
spot.
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return to the Microwave Office environment. When you execute the analysis on 
the whole circuit, the Sonnet analysis results are already available so that 
processing time is minimal.

Working Outside Microwave Office
Using the export and import functions in Sonnet allows you to run analyses in 
Sonnet without locking up Microwave Office for the duration of the processing 
time. However, working outside Microwave Office does require more overhead 
to keep the data consistent in the Microwave Office project. This section of the 
tutorial will demonstrate how to analyze an EM structure in Sonnet without 
locking up Microwave Office for the whole analysis, how to export an EM 
structure from Microwave Office to a Sonnet project and how to import a Sonnet 
project as an EM structure.

39 If it is not already open in Microwave Office, open lowpass.emp.

40 Right-click on the Low Pass Filter EM structure in the Microwave Office 
project browser and select “Open in Native Editor” from the pop-up menu 
which appears.

This opens the EM structure in Sonnet’s project editor.

Normally, you would now make changes to the EM structure before again 
analyzing the circuit. Since we only wish to demonstrate the Export and Import 
features, no changes will actually be made to the circuit.

When you opened the EM structure in Sonnet, the analysis controls set up in 
Microwave Office are transmitted as part of the geometry sent to Sonnet. You 
wish to analyze the circuit but are aware that the processing time is considerable. 
Therefore, you want to analyze the EM structure without locking up Microwave 
Office for the whole processing time of the analysis. To do this, perform the 
following:
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41 Select File ⇒ MWOffice ⇒ Analyze Outside MWOffice from the project 
editor main menu.

A message explaining the command appears on your display. The Analyze 
Outside MWOffice includes the analysis frequency controls from the Microwave 
Office project in the export. If you do not wish to run an analysis right away or 
plan to work on the circuit exclusively in the Sonnet environment, you may use 
the File ⇒ MWOffice ⇒ Save as Sonnet Project command to export the EM 
structure to a Sonnet project. 

TIP
If you do not want this message to appear each time you select this command, you 
may select the Don’t show me this again checkbox. If you later wish to turn the 
message back on, you may do so in the Hints tab of the Preferences dialog box. 
The Preferences dialog box is accessed by selecting File ⇒ Preferences from the 
project editor main menu.

42 Once you have read the message, click on OK to close the message box.

The message box disappears and a Browse window appears on your display.

In order to unlock Microwave Office, you must save the EM structure to a 
temporary Sonnet project location. This window allows you to specify the 
location of the Sonnet project.
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43 Enter the location c:\MWOffice_tutorial.son in the Browse window and 
click on the OK button.

If you wish, you may choose another location on your computer. The Browse 
window closes, then the analysis monitor appears on your display which indicates 
the analysis has begun. Notice that the file name displayed in the title bar of the 
analysis monitor is “MWOffice_tutorial.son.”

44 Select File ⇒ Exit from the project editor main menu.

The project editor closes and Microwave Office is restored on your display. 
Microwave Office is now unlocked and is available for use. The EM structure was 
transmitted back to Microwave Office when the project editor was closed. It is 
important that you select Sonnet as the Native Editor when you use this mode so 
that you can not make changes in Microwave Office to the EM structure while the 
analysis is ongoing in Sonnet. This would cause the geometry to be inconsistent 
with the analysis data. 

45 Wait until the analysis in Sonnet is complete.

Normally, this would take a noticeable amount of time, but since we made no 
changes to the EM structure, the analysis was able to use the data from the 
previous simulation so that the job completes very quickly.
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Now you need to import the temporary Sonnet project file in order to make the 
analysis results available in Microwave Office.

46 Right-click on the EM structure Low Pass Filter in the project browser in 
Microwave Office and select “Open in Native Editor” from the pop-up 
window which appears.

The EM structure is opened in the project editor. You want to replace this with the 
Sonnet project whose analysis just completed.

47 Select File ⇒ MWOffice ⇒ Load Sonnet Project from the project editor 
main menu.

A warning message that you are going to overwrite the EM structure appears on 
your display. 

48 Click on the Continue button.

The message window disappears and a Browse window appears which allows you 
to select the Sonnet project which you wish to load.

49 Select “c:\mwoffice_tutorial.son” in the Browse window.

This is the temporary file to which you saved the EM structure when you executed 
the Analyze Outside MWOffice command in step 43. This command loads the 
project file in, along with the analysis results, in place of the EM structure you 
opened in Microwave Office. 

50 Select File ⇒ Exit from the project editor main menu.

The project editor is closed and the Sonnet project you just loaded is imported into 
Microwave Office for the EM structure. Microwave Office is unlocked and 
restored on your display. 
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51 Select Simulate ⇒ Analyze from the main menu of Microwave Office.

The analysis completes very quickly since the results for Low Pass Filter have 
already been computed. The graph is updated. This should be the same graph as 
shown on page 94 since the EM structure has not been changed. This completes 
the Microwave Office Interface tutorial. 
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