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Chapter 6 GDSII and DXF 
Translator Tutorial

This tutorial teaches you the basics of performing a translation of a GDSII or DXF 
file into a Sonnet project. Since the operation of the two translators is very similar, 
the two translators were combined into one tutorial with separate sections for the 
areas where they differ. For a detailed discussion of the GDSII and DXF 
translators, please see Chapter 15, “The DXF and GDSII Translators” in the 
Sonnet User’s Guide. 

This tutorial describes a simple example. The example is found in the examples 
directory provided with your software and is called “dcblock.dxf” for the DXF 
translator or dcblock.gds for the GDSII translator. 
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These files are a DXF and GDSII file that contain the same two circuits: a coupled 
line structure to be used as a DC block, and a bent transmission line as pictured 
below. The objective of this example is to convert the DXF or GDSII file into a 
Sonnet project and to tweak the file so that the DC block may be analyzed in em.

The DXF or GDSII example file contains two circuits. 
This tutorial uses the top circuit.
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Obtaining the Translator Example Files
You need to copy the example Dcblock from the Sonnet examples. Dcblock is a 
directory which contains the DXF and GDSII files used for input in this example 
in addition to a layer mapping file for the conversion. If you do not know how to 
obtain a Sonnet example, select Help ⇒ Examples from any program menu, then 
click on the Instructions button. If you are reading this manual in the PDF format 
on your computer, click on the link above.

Determine Level Mapping 
First you must determine the mapping of DXF layers to project editor levels. To 
do this you import the DXF file with the default layer mapping. You use the 
resulting project to determine what layers you wish to retain from your DXF file. 
You perform a second import of the same file, this time editing the contents of the 
Layer Mapping dialog box and saving the settings to a layer mapping file for use 
in subsequent imports. 

NOTE: Although you edit the layer mapping for this example, that will not be 
necessary for many DXF files; the default map created by the DXF 
translator will be sufficient. 

1 Invoke the project editor.

The project editor window appears on your display.

2 Select File ⇒ Import ⇒ DXF or File ⇒ Import ⇒ GDSII, depending on 
which translator you are using, from the main menu of the project editor.

A Browse window appears on your display.
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3 Locate the example file “dcblock.dxf” or “dcblock.gds” in your working 
directory and click on the Open button in the browse window.

The Import Control dialog box appears on your display.

For this example, you want to import the file “dcblock.dxf” or “dcblock.gds” to a 
new Sonnet project “dcblock.son”. The default option is to import to a new project 
and the default project name is the basename of the DXF or GDSII file with the 
“.son” extension of a Sonnet project file. No action needs to be taken since the 
defaults are what you want.

NOTE: If you are importing a GDSII file, continue the tutorial at Step 4 below. 
If you are importing a DXF file, continue the tutorial at Step 7 on page 
108. 
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4 Click on the Next button in the Import Control dialog box to continue.

The Structure dialog box appears on your display.

For this example, there is only one structure in the GDSII file; therefore, the 
default option of converting the default structure is acceptable. If the GDSII file 
you are importing has multiple structures, you may select the “Specify Structure” 
option. This enables the Specify button. Clicking on this button opens a list of 
structures available in the GDSII file. You may select which structure you wish to 
convert to the Sonnet project. 
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5 Click on the Next button in the Structure dialog box to continue.

The message “Reading Layers, please wait.” appears in the Import Control dialog 
box. When the project editor finishes obtaining the layer information from the 
GDSII file, the Layer Mapping dialog box appears.

You do not know what mapping you want until you observe the converted file in 
the project editor, so you do not need to change anything in this dialog box at this 
time.
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6 Click on the Next button in the Layer Mapping dialog box to continue.

The Import dialog box appears on your display.

The message “Ready to Import” appears in the output window. Since the default 
option settings are those you wish to use for this file, you do not need to open the 
Import Options dialog box. For information about setting import options, refer to 
the project editor’s Help.

NOTE: Continue the tutorial at Step 8 on page 109.
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7 Click on the Next button in the Import Control dialog box to continue.

The Import dialog box appears on your display.

The message “Ready to Import” appears in the output window. Since the default 
option settings are those you wish to use for this file, you do not need to open the 
Import Options dialog box. For information about setting import options, refer to 
the project editor’s Help.
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8 Click on the Import button in the Import dialog box to execute the conver-
sion.

Progress messages appear above the output window. When the import is 
complete, the DXF or GDSII file information is displayed in the output window.

DXF 
Information

GDSII 
Information
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9 Click on the Close button to close the Import dialog box.

The target project “dcblock.son” is open in the project editor.

Look at each of the circuit levels in the project editor. Since the cell size has not 
yet been defined, it may be difficult to see your circuit. Toggle the cell fill on and 
off at your discretion (using ^M) during the rest of this example.

Notice that there are several layers. The project editor’s level 5 has all of the 
information that we need to do an em analysis. You should now edit the layer 
mapping in the Layer Mapping dialog box so that the conversion uses only this 
layer. To do this, import the file again, but before importing edit the Layer 
Mapping dialog box. 

10 Select File ⇒ Import ⇒ DXF or File ⇒ Import ⇒ GDSII from the project 
editor main menu.

This opens the Browse window. 

11 Once you have located the example file “dcblock.dxf” or “dcblock.gds” click 
on the Open button.

The Import Control dialog box appears on your display.
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12 Select the Import to Present Project option.

This imports the DXF or GDSII file to the same project as before.

NOTE: If you are importing a GDSII file, continue the tutorial at Step 13 be-
low. If you are importing a DXF file, then continue the tutorial at Step 
20 on page 113.

13 GDSII Click on the Next button in the Import Control dialog box to con-
tinue.

The Structure dialog box appears on your display. The default structure is correct.

14 Click on the Next button in the Structure dialog box to continue.

This opens the Layer Mapping dialog box. Now that you know that layer 8 has all 
of the information that is needed to do an em analysis, you edit the inputs of this 
dialog box so that the conversion uses only this layer.

15 Click on the Map checkbox for all the rows except for that containing the 
GDSII Stream number 8. 

This leaves stream layer 8 as the only layer which is used in the conversion. The 
other layers are ignored since the Map checkbox is off. Since there are too many 
layers to display all of them, use the scroll bar to access layers that are not 
presently displayed.

16 Enter “0” in the Xgeom Level text entry box for the Stream number 8 entry.

Since our example is a single layer circuit, you set the Xgeom Level number to 
“0” which is the first level in the project editor. 
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17 Enter “Copper” in the Xgeom Material column in the same row.

Metal is already selected as the Xgeom Object type. The type of metal you wish 
to use is Copper. Since the metal “copper” is not defined in the project file, you 
will need to define its attributes later. Your Layer Mapping dialog box should look 
similar to below.

If you wish to save the settings to use for future imports of this file, you would 
click on the Save button which allows you to save the settings to an external layer 
file. To load an external layer file, click on the load button.

18 Click on next in the Layer Mapping dialog box to continue.

19 Click on Import in the Import dialog box to complete the import.

Once the import is complete, click on the Close button in the Import dialog box. 
The file “dcblock.son” should be open in the project editor.

NOTE: If you are importing a GDSII file, continue the tutorial at “Define Di-
electric Layer and Metallizations,” on page 115.
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20 To Continue the DXF tutorial, click on the Next button in the Import Con-
trol dialog box to continue.

The Import dialog box appears on your display and messages indicate that the 
layers have been read from the file by the DXF translator.

21 Click on the Layers button to open the Layer Mapping dialog box.

This opens the Layer Mapping dialog box. Now that you know that layer 5 has all 
of the information that is needed to do an em analysis, you edit the inputs of this 
dialog box so that the conversion uses only this layer.

22 Click on the Map checkbox for all the rows except for that containing the 
Xgeom level 5. 

This leaves DXF layer “Filter” as the only layer which is used in the conversion. 
The other layers are ignored since the Map checkbox is off. Since there are too 
many layers to display all of them, use the scroll bar to access layers that are not 
presently displayed.

23 Enter “0” in the Xgeom Level text entry box for the DXF Layer “Filter” 
entry.

Since our example is a single layer circuit, you set the Xgeom Level number to 
“0” which is the first level in the project editor. 
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24 Enter “Copper” in the Xgeom Material column in the same row.

Metal is already selected as the Xgeom Object type. The type of metal you wish 
to use is copper. Since the metal “copper” is not defined in the project file, you 
will need to define its attributes later. Your Layer Mapping dialog box should look 
similar to below.

If you wish to save the settings to use for future imports of this file, you would 
click on the Save button which allows you to save the settings to an external layer 
file. To load an external layer file, click on the load button.

25 Click on OK in the Layer Mapping dialog box to continue.

You return to the Import dialog box.

26 Click on the Options button in the Import dialog box.
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The Import Options dialog box appears on your display. This example was input 
in microns. Since the default Units value is inches, you need to change this before 
importing the circuit.

27 Select “microns” from the Units drop list.

The DXF translator will use microns as the length unit when it imports the DXF 
file.

28 Click on the OK button to apply the changes.

The Options dialog box closes. You are ready to import your DXF file.

29 Click on Import in the Import dialog box to complete the import.

Once the import is complete, click on the Close button in the Import dialog box. 
The file “dcblock.son” should be open in the project editor.

Define Dielectric Layer and Metallizations
Now define the metallization and dielectric layer parameters in the project editor. 
The procedure is the same as making these changes for any normal project.
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In this example, set the top dielectric layer to 1000 microns of air (Erel=1.0) and 
the bottom dielectric to 100 microns of GaAs (Erel=12.9) in the Dielectric Layers 
dialog box. Also, in the Metal Types dialog box, edit the entry for copper using 
the Normal metal type and setting the Conductivity to 5.8E7 S/m, the Thickness 
to 15 microns and the Current Ratio to 0.

Remove Parts of the Circuit Not Being Used
Before you do the deletes and clips, you may want to save your file. 

You may have converted a much larger section of the circuit than you want to 
analyze with em. Thus you may want to delete large sections of the circuit from 
multiple levels. You may even need to delete entire levels using Circuit ⇒ 
Dielectric Layers. In our example, we used the Layer Mapping dialog box to 
delete extra metal levels that we did not need, but all the dielectric layers were 
imported. Either way is acceptable since dielectric layers without metal on them 
do not affect processing time or memory requirements.

Use Edit ⇒ Clip to window out a part of the circuit you wish to analyze. To 
window out a precise area, you may need to turn the snap off before selecting Edit 
⇒ Clip.

You can also delete several polygons at once by using Select ⇒ Single Layer or 
Select ⇒ Mult. Layer to select several polygons and points. Press the “Delete” key 
to delete the selected objects. Remember, any place where you can remove metal 
that does not affect your answer shortens em execution time.
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In our example, save your file and then use Edit ⇒ Clip as shown below. The RF 
probe structure is calibrated out in the measurement so it should not be included 
in the em analysis.

Decide on a Substrate Size and Cell Size
Based on your geometry, you should decide on your cell size and substrate size. 
Remember to first set the area size to a multiple of the cell size. Since you have 
deleted a large portion of the circuit, you may now need to resize your substrate. 
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Next, you need to set the size of the substrate. Select Circuit ⇒ Box to open the 
Box Settings dialog box. Now click on the Set Box Size with Mouse button, then 
lasso the area around the remaining circuit. This is done to get a box size 
approximately “close” to the final box size.

Then, precisely set the x dimension of the box to 1800 microns and the y 
dimension of the box to 800 microns by entering the values in the text entry boxes 
in the Box Settings dialog box. Now set the cell size to 10 microns by 10 microns. 
Notice that we selected a substrate size that was a multiple of the cell size. Click 
on the OK button to apply the new box size and close the dialog box.

Change Polygons to Have the Proper Fill
Change the polygon fill (subsection type) if needed. For example, you may need 
to change several polygons from Staircase fill to Diagonal fill. To change several 
polygons at one time, you can select multiple polygons then use Modify ⇒ Metal 
Properties.

Our example does not need to have the polygon fill changed.
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Align the Circuit to Grid Points
Now check to see how em will subsection your circuit. To do this, make sure the 
cell fill is turned “On”. The cell fill shows you how em will subsection your 
circuit. If you did not choose a small enough cell size or if your circuit is not 
oriented exactly on grid points, the metal may “short” two polygons together. This 
happens in our example as pictured below. The problem shown in the figure can 
be fixed by moving the entire circuit by a fraction of a cell.

For our example, turn the cell snap off, using Tools ⇒ Snap Setup to open the 
Snap Grid Setup dialog box. Click on the No Snap radio button to turn the snap 
off. Click on the OK button to apply the changes and close the dialog box. Now, 

Shorted Polygons
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using Edit ⇒ Select All, move your circuit so that the circuit is aligned to the grid 
points. Do not worry about getting the circuit exactly aligned. Notice that the 
polygons are no longer “shorted” together.

TIP
You may use the shortcut key, ctrl-A for the command Edit ⇒ Select All

At this point you may want to snap all of the polygons to grid points. Before you 
do the snap, you may want to save your file. Select all of the polygons. Now select 
Modify ⇒ Snap to from the menu. Click on the X and Y radio button in the Cells 
section of the Snap Objects dialog box which appears. Then select the Preserve 
Spacing and Shape Relative to the Reference Point radio button. Click on the 
Select Reference Point button and select a reference point in your circuit. All other 
vertices in your circuit will be snapped relative to the position of this reference 
point so that the shape of the imported circuit is maintained. When the dialog box 
reappears, click on the OK button to close the dialog box and snap the circuit to 
the grid. 

If desired, you can select only parts of the circuit to snap to the grid points.
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Move Points Around as Needed
Some points may now need to be moved. Pay particular attention to mitered 
corners and narrow lines and gaps. 

Our example needs to be centered. Make sure the snap is set to cell snap (Tools ⇒ 
Snap Setup and select Cell Size) and choose Edit ⇒ Select All. Now move your 
circuit to the approximate center of your substrate.

Add Vias
Next, add vias as needed. The metallization being put down in a standard DXF file 
may only represent the mask dimensions and layers and not the actual physical 
dimensions or location of the via. You may need to create each via by hand.

Our example does not require vias.
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Add Ports and Reference Planes
To finish the example, add ports and reference planes. Typically this entails 
extending transmission lines to bring the circuit out to the edge by using Tools ⇒ 
Reshape and Modify ⇒ Snap To. The finished circuit is shown below.

You may now analyze this circuit using em. It should have approximately 200 
subsections if analyzed at 10 GHz.
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