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Chapter 1  Setting Up Remote em Processing for Windows
Chapter 1 Setting Up Remote 
em Processing for 
Windows

It is possible to edit your circuit on a local computer, then run the em analysis on 
a remote server on your network. A common reason for doing this is that there is 
a more powerful, faster computer on your network that you want to run your 
analyses on in order to finish them faster. But the faster machine is in an 
inconvenient location, so you want to continue editing your circuits on the 
computer at your desk. Remote processing allows you to do this. 

NOTE: Remote em processing is only available if all of your Sonnet em 
licenses are floating licenses. 

The more powerful, faster computer is your analysis server machine. The 
computer on your desk is your analysis client machine. For the rest of this 
discussion, we will refer to these as your server machine and your client machine.

In order to use remote processing, you must set up the server machine on which 
you will run the analyses and the client machine on which you will edit projects 
and from which you will submit your analysis jobs. Note that the license server 
is different from the analysis server and may or may not be a different computer. 

The program emserver needs to run on the analysis server computer. This program 
accepts analysis jobs from client machines for submission on the analysis server. 
7
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To run your analyses on a remote server, you must first install Sonnet software on 
both the server and client machine, obtain your license from Sonnet and ensure 
that Sonnet is able to run on both machines. See Chapter 3,  “Installation for 
Most Users” in the Windows Installation manual for directions on installing 
Sonnet.

To run your analyses on a remote server:

•  You need to start running emserver on the analysis server machine 
on which you wish to execute the remote analysis. To do this, you 
use the emserver interface which you access by selecting Admin ⇒ 
Emserver Status/Control from the Sonnet task bar main menu. You 
may also wish to set your server to automatically start emserver at 
power-up.

NOTE: If you have a firewall enabled on your analysis server, it must be 
configured such that the program, “emserver.exe” has permission to 
run. Windows XP users should be aware that Service Pack 2 or above 
automatically runs a hidden firewall. Please refer to your system 
administrator for instructions on configuring your firewall. 

• Next, you need to set up your client machine by defining 
emserver’s location and configuring the client for remote 
processing. By default, a computer performs only local analyses. 
When you configure your client, you may select a default server or 
you can choose to be prompted to select a server from all the 
available servers defined for this client. You may choose to include 
your local computer in the list of available analysis servers. You 
use the Preferences dialog box in the analysis monitor to configure 
the client system.

• Once the server and client are both configured, you should run an 
analysis to confirm that everything is operating correctly. When 
you run an analysis, you are prompted to choose a server for your 
analysis (if you selected this option when configuring your client). 
The rest of this chapter contains detailed instructions for 
accomplishing these tasks. 

Configuring the Analysis Server

First set up the server on the machine on which you wish to execute the remote 
analysis. This machine will need to run the program emserver, which controls the 
em analysis of remote jobs submitted to this server. 

1 Open the Sonnet task bar on the server machine.
8
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2 Select Admin ⇒ Emserver Status/Control from the task bar main menu. 

The Emserver Status/Control window appears on your display. This window 
allows you to start, stop and control the functions of the program emserver. 

3 Click on the Advanced button at the bottom of the Emserver Status/Control 
window. 

This opens the Emserver Advanced Settings dialog box. 

If you wish to have emserver startup automatically upon reboot, you would click 
on the Server tab and select the Start Emserver at Powerup checkbox and for 
Win2000/ XP you would also select the Use Services checkbox.

NOTE: If you assign emserver to a service, you should take care not to use 
mapped network drives for paths specified in the Emserver Status/
Control window. Network drives not on the local machine should be 
specified using the full pathname. For example, if “J” is mapped to 
“\\galaxy1\tmp” on your network, then the project path should be 
specified by “\\galaxy1\tmp\sonnnet_remote_em” instead of 
“J:\sonnet_remote_em.”

4 Click on the Data tab of the Emserver Advanced Settings dialog box.

When the analysis server is processing a remote em job, it copies the submitted 
project file from the client to a temporary data directory. This data directory does 
not have to be on the server machine, but it is recommended that you use a local 
disk whenever possible for efficiency. Analysis data is returned to the client as it 
is produced, but a copy is maintained on the analysis server in case a disconnect 
occurs between the server and client. Once the analysis is complete, the project 
copy is deleted from the analysis server. This Data tab allows you to specify the 
location of the temporary data directory on the server machine. 
9
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5 Enter the desired directory for the temporary data directory in the Data 
Directory text entry box.

The default varies depending on the operating system. You may specify any 
directory on the client machine. If you wish, click on the Browse button to open a 
browse window which allows you to select a directory.

6 Click on the OK button to close the Emserver Advanced Settings dialog box 
and apply any changes that might have been made.

7 Click on the Start Emserver button in the Emserver Status/Control window. 

The message “Emserver running” should appear in the window above the job list. 
The job list should contain the message “Emserver processing 0 jobs.” This 
indicates that emserver is up and running on your server machine. 

8 Click on the OK button to close the Emserver Status/Control window. 

This does not stop emserver; the program continues to run. For information about 
other status and control functions, refer to the Sonnet task bar online help topic 
Admin ⇒ Emserver Status/Control. 

This completes setting up the server machine. The next task is to configure the 
client machine for remote processing.

Configuring the Analysis Client 

Next, you need to set up your client machine, which is the local machine at which 
you edit your projects and from which you will submit processing jobs. 

1 Click on the Analyze Project button on the Sonnet task bar and select “New 
Batch” from the pop-up menu which appears on your display. 

The analysis monitor window appears on your display with no jobs in the batch.

2 Select File ⇒ Preferences from the analysis monitor main menu. 

The Preferences dialog box appears on your display.

3 Click on the Enable running on remote computers radio button to enable 
remote processing. 

The default setting is Run on local computer which does not allow remote 
processing. Clicking on this radio button enables the rest of the controls in this 
dialog box. Notice the Default Server drop list. This is blank since there have been 
no remote servers added to the server list yet. 
10
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4 Click on the Edit Server List button just above the Default Server drop list. 

The Edit Server List dialog box appears on your display. This dialog box allows 
you to create, delete and edit entries in your server list. You may have multiple 
remote servers in this list. 

5 Click on the Add Server button to open the Add/Edit Remote Server dialog 
box. 

You can specify your remote server by Host Name or IP Address. 

6 Select the appropriate radio button and enter the corresponding 
information in the adjacent text entry box. 

This identification should match the identification entered in the Emserver 
Advanced Settings dialog box when you set up the server machine.

7 Click on the Test Connection to Remote Emserver Process. 

The client machine attempts to communicate with the emserver program on the 
server machine. A window appears with a status output. If the connection operates 
correctly, the message “Valid Connection established to emserver” appears. If you 
receive an error message, the client machine was not able to establish a connection 
to the server machine. One of the following situations is likely:

• You entered the host name or IP address incorrectly.

• The client machine does not recognize the host name you entered.

• emserver is not running on the server machine.

• You do not have a working network connection to the server 
machine. 

8 Click on the OK button in the Testing Server Connection status window to 
close it.

9 If desired, enter a comment in the Comment text entry line. 

This may be used as a brief description to identify the server machine. This 
comment is displayed on the server's entry line in the server list.

10 Click on the OK button in the Add/Edit Remote Server dialog box to close it 
and apply the changes. 

The remote server you just specified should now appear in the server list in this 
dialog box.
11
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11 If you wish to have your local computer appear as a choice of server when 
you submit analysis jobs, select the Include local computer in server list 
checkbox. 

When a list of servers appears in the New Batch Creation dialog box, your local 
server appears among them.

12 Click on the OK button to close the Edit Server List dialog box and apply 
the changes. 

The remote server you just specified appears in the Default Server drop list. If 
there were multiple servers defined you would use this drop list to choose the 
default server.

13 Select the Prompt for server instead of default, if you wish to have a choice 
of servers when you launch an analysis. 

If this checkbox is selected, the New Batch Creation dialog box appears when you 
open a new batch in the analysis monitor. This dialog box allows you to select any 
of the defined servers for the analysis. If this checkbox is cleared, then the default 
server you selected in the Default Server drop list is used for all analysis jobs. 

14 Click on the OK button to close the Preferences dialog box. 

The changes made in the Preferences dialog box do not apply to the present 
analysis monitor window. They will be used the next time the analysis monitor is 
invoked.

15 Select File ⇒ Exit from the analysis monitor main menu. 

This exits the analysis monitor and completes the setup of the client machine.

This completes setting up the client machine. Once the server and client are both 
configured, you should run an analysis to confirm that everything is operating 
correctly.

Running an Analysis on a Remote Server.

In order to run an analysis on a remote server, you must first be running emserver 
on the server machine and have configured the client machine to run an analysis 
remotely.

To run an analysis on a remote server, do the following:
12
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1 Open a Sonnet project that is ready for analysis in the project editor and 
click on the Analyze button on the project editor's tool bar. 

The New Batch Creation dialog box appears on your display. This dialog box 
contains a list of the remote servers that have been setup for this client system. If 
you chose to include your local computer in the server list when you configured 
the client, then your local computer appears in this server list.

Note that the New Batch Creation dialog box only appears if you selected the 
Prompt for Server option in Step 13 on page 12. If this option was not selected, 
the analysis monitor appears on your display.

2 Click on the desired server to select it for the analysis, then click on the OK 
button in the New Batch Creation dialog box. 

This closes the dialog box. This server is now associated with the analysis monitor 
window which will subsequently open. All jobs added to the batch list of the 
analysis monitor will be analyzed on the server chosen here. The analysis monitor 
appears on your display and your analysis job starts running. The rest of the 
analysis proceeds in the same manner as an analysis run on your local computer. 
If any errors occur with the server, a status message is posted in the status section 
of the analysis monitor just under the progress bar. 

If there is a loss of communication between the analysis server and analysis client 
while an analysis is running, it is possible to reconnect to an ongoing analysis or 
recover the results of a completed analysis. For details on reconnecting or 
recovering disconnected jobs, please see online Help for the analysis monitor.
13
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Chapter 2 Setting up Remote 
em Processing for 
UNIX & Linux

It is possible to edit your circuit on a local computer, then run the em analysis on 
a remote server on your network. A common reason for doing this is that there is 
a more powerful, faster computer on your network that you want to run your 
analyses on in order to finish them faster. But the faster machine is in an 
inconvenient location, so you want to continue editing your circuits on the 
computer at your desk. Remote processing allows you to do this. 

NOTE: Remote em processing is only available if all of your Sonnet licenses 
are floating licenses for em. 

The more powerful, faster computer is your analysis server machine. The 
computer on your desk is your analysis client machine. For the rest of this 
discussion, we will refer to these as your server machine and your client machine.

In order to use remote processing, you must set up the server machine on which 
you will run the analyses and the client machine on which you will edit projects 
and from which you will submit your analysis jobs. Note that the license server 
is different from the analysis server and may or may not be a different computer. 
You may also use different types of platforms; for instance, you could have a 
UNIX analysis server with a PC analysis client.
15
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The program emserver needs to run on the analysis server computer. This program 
accepts analysis jobs from client machines for submission on the analysis server. 

To run your analyses on a remote server, you must first install Sonnet software on 
both the server and client machine, obtain your license from Sonnet and ensure 
that Sonnet is able to run on both machines. See the UNIX Installation Manual 
for directions on installing Sonnet.

To run your analyses on a remote server:

• You need to start running emserver on the analysis server machine 
on which you wish to execute the remote analysis. To do this, you 
use the emserver interface which you access by selecting Admin ⇒ 
Emserver Status/Control from the Sonnet task bar main menu. You 
may also wish to set your server to automatically start emserver at 
power-up.

NOTE: If you have a firewall enabled on your analysis server or client 
machine, it must be configured such that the program, “emserver” 
has permission to run. Please refer to your system administrator for 
instructions on configuring your firewall. 

• Next, you need to set up your client machine by defining 
emserver’s location and configuring the client for remote 
processing. By default, the client performs only local analyses. 
When you configure your client, you may select a default server or 
you can choose to be prompted to select a server from all the 
available servers defined for this client. You may choose to include 
your local computer in the list of available analysis servers. You 
use the Preferences dialog box in the analysis monitor to configure 
the client system.

• Once the server and client are both configured, you should run an 
analysis to confirm that everything is operating correctly. When 
you run an analysis, you are prompted to choose a server for your 
analysis (if you selected this option when configuring your client). 
The rest of this document contains detailed instructions for 
accomplishing these tasks. 

Configuring the Analysis Server

First set up the server on the machine on which you wish to execute the remote 
analysis. This machine will need to run the program emserver, which controls the 
em analysis of remote jobs submitted to this server. 
16



Chapter 2  Setting up Remote em Processing for UNIX & Linux
1 Open the Sonnet task bar on the server machine.

2 Select Admin ⇒ Emserver Status/Control from the task bar main menu. 

The Emserver Status/Control window appears on your display. This window 
allows you to start, stop and control the functions of the program emserver. 

If you wish to have emserver startup automatically upon reboot, see “Automatic 
Startup of emserver” on page 22.

3 Click on the Advanced button at the bottom of the Emserver Status/Control 
window.

The Emserver Advanced Settings dialog box appears on your display.

4 Click on the Data tab of the Emserver Advanced Settings dialog box.

When the analysis server is processing a remote em job, it copies the submitted 
project file from the client to a temporary data directory. This data directory does 
not have to be on the server machine, but it is recommended that you use a local 
disk whenever possible for efficiency. Analysis data is returned to the client as it 
is produced, but a copy is maintained on the analysis server in case a disconnect 
17
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occurs between the server and client. Once the analysis is complete, the project 
copy is deleted from the analysis server. This Data tab allows you to specify the 
location of the temporary data directory on the server machine. 

5 Enter the desired directory for the temporary data directory in the Data 
Directory text entry box.

The default for UNIX is “/var/tmp/sonnet_remote_em”. However, you may 
specify any directory on the server machine or on the network. If you wish, click 
on the Browse button to open a browse window which allows you to select a 
directory.

6 Click on OK to close the dialog box and apply the changes.

The Emserver Advanced Settings dialog box is closed. 
18
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7 Click on the Start Emserver button in the Emserver Status/Control window. 

The message “Emserver running” should appear in the window above the job list. 
The job list should contain the message “Emserver processing 0 jobs.” This 
indicates that emserver is up and running on your server machine.

8 Click on the OK button to close the Emserver Status/Control window. 

This does not stop emserver; the program continues to run. For information about 
other status and control functions, refer to the Sonnet task bar online help topic 
Admin ⇒ Emserver Status/Control. 

This completes setting up the server machine. The next task is to configure the 
client machine for remote processing.

Configuring the Analysis Client 

Next, you need to set up your client machine, which is the local machine at which 
you edit your projects and from which you will submit processing jobs. 

1 Click on the Analyze Project button on the Sonnet task bar and select “New 
Batch” from the pop-up menu which appears on your display. 

The analysis monitor window appears on your display with no jobs in the batch.

2 Select File ⇒ Preferences from the analysis monitor main menu. 

The Preferences dialog box appears on your display.

Status
Message
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3 Click on the Enable running on remote computers radio button to enable 
remote processing. 

The default setting is Run on local computer which does not allow remote 
processing. Clicking on this radio button enables the rest of the controls in this 
dialog box. Notice the Default Server drop list. This is blank since there have been 
no remote servers added to the server list yet. 

4 Click on the Edit Server List button just above the Default Server drop list. 

The Edit Server List dialog box appears on your display. This dialog box allows 
you to create, delete and edit entries in your server list. You may have multiple 
remote servers in this list. 

5 Click on the Add Server button to open the Add/Edit Remote Server dialog 
box. 

You can specify your remote server by Host Name or IP Address. 

6 Select the appropriate radio button and enter the corresponding 
information in the adjacent text entry box. 

7 Click on the Test Connection to Remote Emserver Process. 

The client machine attempts to communicate with the emserver program on the 
server machine. A window appears with a status output. If the connection operates 
correctly, the message “Valid Connection established to emserver” will appear. If 
you receive an error message, check the following:

a. Ensure that emserver has been properly started on the server machine.

b. Check that you have entered the correct name or IP address for the server 
in the Add/Edit Remote Server dialog box. Note that if you enter a name 
for a remote server, that name MUST be defined in the hosts file on the 
client machine. See your system administrator for details on editing the 
hosts file.

c. Check the network connection between the server and client. Make sure 
that you can ping the server from the client. If you do not know how to 
ping the server, please see your system administrator for details.

8 Click on the OK button in the Testing Server Connection status window to 
close it.

9 If desired, enter a comment in the Comment text entry line. 

This may be used as a brief description to identify the server machine. This 
comment is displayed on the server's entry line in the server list.
20
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10 Click on the OK button in the Add/Edit Remote Server dialog box to close it 
and apply the changes. 

The remote server you just specified should now appear in the server list in this 
dialog box.

11 If you wish to have your local computer appear as a choice of server when 
you submit analysis jobs, select the Include local computer in server list 
checkbox. 

When a list of servers appears in the New Batch Creation dialog box, your local 
server appears among them.

12 Click on the OK button to close the Edit Server List dialog box and apply 
the changes. 

The remote server you just specified appears in the Default Server drop list. If 
there were multiple servers defined you would use this drop list to choose the 
default server.

13 Select the Prompt for server instead of default, if you wish to have a choice 
of servers when you launch an analysis. 

If this checkbox is selected, the New Batch Creation dialog box appears when you 
open a new batch in the analysis monitor. This dialog box allows you to select any 
of the defined servers for the analysis. If this checkbox is disabled, then the default 
server you selected in the Default Server drop list is used for all analysis jobs. 

14 Click on the OK button to close the Preferences dialog box. 

The changes made in the Preferences dialog box do not apply to the present 
analysis monitor window. They will be used the next time the analysis monitor is 
invoked.

15 Select File ⇒ Exit from the analysis monitor main menu. 

This exits the analysis monitor and completes the setup of the client machine.

This completes setting up the client machine. Once the server and client are both 
configured, you should run an analysis to confirm that everything is operating 
correctly. 

Running an Analysis on a Remote Server.

In order to run an analysis on a remote server, you must first be running emserver 
on the server machine and have configured the client machine to run an analysis 
remotely.
21
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To run an analysis on a remote server, do the following:

1 Open a Sonnet project that is ready for analysis in the project editor and 
click on the Analyze button on the project editor's tool bar. 

The New Batch Creation dialog box appears on your display. This dialog box 
contains a list of the remote servers that have been setup for this client system. If 
you chose to include your local computer in the server list when you configured 
the client, then your local computer appears in this server list.

Note that the New Batch Creation dialog box only appears if you selected the 
Prompt for Server option in Step 13 on page 21. If this option was not selected, 
the analysis monitor appears on your display and the job starts running.

2 Click on the desired server to select it for the analysis, then click on the OK 
button in the New Batch Creation dialog box. 

This closes the dialog box. This server is now associated with the analysis monitor 
batch window which will subsequently open. All jobs added to the batch list of the 
analysis monitor will be analyzed on the server chosen here. The analysis monitor 
appears on your display and your analysis job starts running. The rest of the 
analysis proceeds in the same manner as an analysis run on your local computer. 
If any errors occur with the server, a status message is posted in the status section 
of the analysis monitor just under the progress bar. 

If there is a loss of communication between the analysis server and analysis client 
while an analysis is running, it is possible to reconnect to an ongoing analysis or 
recover the results of a completed analysis. For details, on reconnecting or 
recovering disconnected jobs, please see online Help for the analysis monitor.

Automatic Startup of emserver

Typically, you will want to start up emserver each time you reboot the analysis 
server. To do this you must make a change to your system startup files on the 
analysis server to start up the emserver program automatically upon bootup. This 
is different on each platform. See below for instructions on how to do this for your 
platform. 

SPARCstations (Solaris)

1 Copy the file <Sonnet Directory>/data/S90SunSonnetEmserver to the “/etc/
rc3.d” directory, where <Sonnet Directory> is the directory in which Sonnet 
software was installed. 
22
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NOTE: You will need root privileges to do this. See your system administrator 
if necessary.

2 Edit the S90SunSonnetEmserver file to enter the correct directory for 
$SONNET_DIR. 

This should be the directory in which Sonnet software was installed. 

3 Remove the # from the beginning of the line to make it executable.

A “#” as the first character indicates that the line is a comment.

4 Make S90SunSonnetEmserver executable.

To do this, type:

cd /etc/rc3.d
chmod +x S90SunSonnetEmserver

HP-UX

For HP-UX 10.2 and above, follow the instructions in the file 

<Sonnet Directory>/data/hpux.txt.

where <Sonnet Directory> is the directory in which the Sonnet Software was 
installed.

Linux

To change your system startup files for a Linux system, you must run the program 
soninstallservice. For instructions on how to use this program, type the following:

cd <Sonnet Directory>
bin/soninstallservice -h

where <Sonnet Directory> is the directory in which the Sonnet Software was 
installed.
23
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